Autor Wątek: Naprawa sygnału Composite w szaraku issue 3 (jak sprawdzić, tranzystory)?  (Przeczytany 821 razy)

perinoid

  • *
  • Wiadomości: 36
  • Miejsce pobytu:
    Warszawa
  • Pomógł: 0
Chciałem "naprawić" sygnał na wyjściu composite w moim szaraku (128K +2), również po to, żeby później zrobić composite-mod. Po obróceniu TR4 obraz na wyjściu composite w złączu RGB się objawił (najpierw w zasadzie nie było), ale był "pocięty" paskami idącymi prawo-góra do lewo-dół pod kątem ok.45 stopni. To bym jeszcze zdzierżył, ale po zrobieniu composite-mod na modulatorze, nie było nadal sygnału wyjściowego (bardzo ciemny, bez kolorów, nieużywalny). No to stwierdziłem, że trzeba odwrócić pozostałe 2N3904, co zrobiłem. Ale efekt był taki, że composite przez wyjście RGB się popsuł (był "w paski" ale w miarę ostry i kolorowy, teraz jest dużo gorszy), a na wyjściu ze zmodowanego modulatora sygnału nie ma wogóle.

Zanim zacznę obracać tranzystory z powrotem, chciałem zapytać, czy jest coś jeszcze, co powinienem zrobić? Może to być efekt spalenia któregoś z tych obracanych tranzystorów podczas wylutowywawnia? Wiem że jeszcze w grę wchodzi odłączenie sygnału audio, czyli sprawa kondensatora C21, ale jeśli jednak sfajczyłem tranzystor, to lepiej będzie najpierw go wymienić, a dopiero potem iść dalej.
Zielono mi... w temacie Spectrum. Ale zawsze się można douczyć.

Klaud

  • *****
  • Wiadomości: 1345
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • Pomógł: 30
  • Mordimer Madderdin
Najpierw odlacz ten nieszczęsny kondensator C31 od wejścia LUMI TEA2000. Jak chcesz mieć dźwięk w TV po wejściu antenowy, wepnij go pomiędzy TR1 a R4
 Jak masz miernik, co potrafi testować diody, to możesz nim także przedwonic dowolny tranzystor bez wylutowania.

Z tego co piszesz fabrycznie miałeś tylko odwrócony TR4. Teraz masz odwrócone pozostałe a TR4 poprawnie wbudowany :). Dotykales TR7?

Co za modyfikacje robisz na modulatorze?
« Ostatnia zmiana: 2017.02.05, 18:50:14 wysłana przez Klaudiusz »
KL
-----
Uzbierane ZXy i klony:
48K i2, i3B, i4A, i6, 48K+ i6, 128K i6U, +2B i2, +3 (napęd FDD do naprawy), Timex 2048 i5, Harlequin 48K iF, iG & Chrome 128K i3A.

perinoid

  • *
  • Wiadomości: 36
  • Miejsce pobytu:
    Warszawa
  • Pomógł: 0
Dzięki za odzew.
Według rysunków na płycie, wszystkie trzy tranzystory były fabrycznie obrócone (czyli były wlutowane tak jak płyta "nakazuje"). Znaczy, teraz po mojej interwencji powinny być elektronicznie właściwie ułożone, chociaż nie pasują do obwiedni tranzystorów na płycie. Jutro spróbuję je odwrócić z powrotem i zrobić porządek z tym kondensatorem. Audio na wyjściu jest mi potrzebne w zasadzie wyłącznie dla złącza RGB, ale na niego jest doprowadzony osobnym kabelkiem podpiętym do gniazda jack, co - jeśli dobrze rozumiem - oznacza, że nie jest to tu problemem.
Zielono mi... w temacie Spectrum. Ale zawsze się można douczyć.

Klaud

  • *****
  • Wiadomości: 1345
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • Pomógł: 30
  • Mordimer Madderdin
Wyjście audio (mono) jest tylko z gniazda słuchawkowego. W +128/+2 (szary) nie ma audio na wyjściu DIN. Na pinie 1 wyjścia DIN masz zespolony sygnał wideo prosto z tego TR4.

Jak sprawdziłeś, że tranzystory były fabrycznie odwrócone? Najczęstszym błędem było złe zamontowanie tranzystorów 2N3904 (TR4, TR5 i TR7) przez fabrykę, błąd w oznaczeniu na PCB. Inne typy były wlutowane poprawnie.

Napisz dokładnie, które tranzystory odwróciłeś oraz co to za modyfikację rzeźbisz? Znam tylko jedną przydatną i nie ma nic wspólnego z modulatorem RF a dotyczy układu TEA2000.

Zapoznaj się z instrukcją serwisową do +2. Przydatna jest i masz tam schemat.
KL
-----
Uzbierane ZXy i klony:
48K i2, i3B, i4A, i6, 48K+ i6, 128K i6U, +2B i2, +3 (napęd FDD do naprawy), Timex 2048 i5, Harlequin 48K iF, iG & Chrome 128K i3A.

perinoid

  • *
  • Wiadomości: 36
  • Miejsce pobytu:
    Warszawa
  • Pomógł: 0
Jak sprawdziłeś, że tranzystory były fabrycznie odwrócone? Najczęstszym błędem było złe zamontowanie tranzystorów 2N3904 (TR4, TR5 i TR7) przez fabrykę, błąd w oznaczeniu na PCB. Inne typy były wlutowane poprawnie.
No... optycznie :-D Na płycie są narysowane obwiednie, jak tranzystory powinny być zamontowane (takie okręgi ścięte z jednej strony). I tranzystory (cały czas mowa wyłącznie o TR4, TR5 i TR7) były wlutowane dokładnie tak, jak te "rysunki" pokazują. Obrócenie TR4 pomogło na wyjście na złączu RGB, więc przynajmniej ten jeden był źle zamontowany.

Napisz dokładnie, które tranzystory odwróciłeś oraz co to za modyfikację rzeźbisz? Znam tylko jedną przydatną i nie ma nic wspólnego z modulatorem RF a dotyczy układu TEA2000.
Już pisałem w pierwszym poście - najpierw obróciłem TR4, co dało poprawę ale wyłącznie na sygnale composite na wyjściu RGB. Potem idąc za ciosem obróciłem TR5 i TR7 i to sprawę popsuło.

Zapoznaj się z instrukcją serwisową do +2. Przydatna jest i masz tam schemat.
Dzięki. Już ściągam.

Jeszcze w kwestii uzupełnienia - mam miernik z opcją sprawdzania diód, jutro zerknę jak wygląda sprawa moich tranzystorów.
Zielono mi... w temacie Spectrum. Ale zawsze się można douczyć.

perinoid

  • *
  • Wiadomości: 36
  • Miejsce pobytu:
    Warszawa
  • Pomógł: 0
Po obróceniu (na fabryczną pozycję) TR7 obraz wrócił. Niejako "dla towarzystwa" odkręciłem również TR5. Po wylutowaniu kondensatora C31 obraz jest akceptowalny (z niebieską poświatą, ale może być). Co prawda C31 mi się przy tym rozwalił, ale trudno, kupię nowy. A na razie nie jest niezbędny, z sygnału z modulatora i tak nie korzystam.
Zielono mi... w temacie Spectrum. Ale zawsze się można douczyć.

Klaud

  • *****
  • Wiadomości: 1345
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • Pomógł: 30
  • Mordimer Madderdin
C31 ma chyba 33pF i powinien byc o tolerancji 2%. Nie jest on latwo dostepny.

Aby wyeliminowac te wkurzajaca niebisko-zolta poswiate, dodaj na TEA2000 szeregowy filtr LC (15uH + 82pF).

Pewnie masz cos takiego na ekranie:


W filtr wlutuj pomiedzy LUMI (pin 8 ) a GND (pin 17), tak jak pokazlem to na tym zdjeciu:


Po tej zabawie obraz powinien wygladac tak:

« Ostatnia zmiana: 2017.02.07, 13:31:46 wysłana przez Klaudiusz »
KL
-----
Uzbierane ZXy i klony:
48K i2, i3B, i4A, i6, 48K+ i6, 128K i6U, +2B i2, +3 (napęd FDD do naprawy), Timex 2048 i5, Harlequin 48K iF, iG & Chrome 128K i3A.

perinoid

  • *
  • Wiadomości: 36
  • Miejsce pobytu:
    Warszawa
  • Pomógł: 0
Ano, tak właśnie mam. Dziękuję za podpowiedź filtra. Zrobię tak, tylko muszę skombinować diodę i odpowiedni kondensator.
Zielono mi... w temacie Spectrum. Ale zawsze się można douczyć.

Klaud

  • *****
  • Wiadomości: 1345
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • Pomógł: 30
  • Mordimer Madderdin
Nie ma tam diody! Potrzebujesz jeden kondensator i jeden dlawik osiowy. Jak masz jakieś różne kondensatory od 30 do 100pF po podaj ich wartości, a podpowiem jak je poskładać. Najlepiej napisz na PW.
KL
-----
Uzbierane ZXy i klony:
48K i2, i3B, i4A, i6, 48K+ i6, 128K i6U, +2B i2, +3 (napęd FDD do naprawy), Timex 2048 i5, Harlequin 48K iF, iG & Chrome 128K i3A.

perinoid

  • *
  • Wiadomości: 36
  • Miejsce pobytu:
    Warszawa
  • Pomógł: 0
Bardzo dziękuję za pomoc. Chyba mogę ogłosić sukces - po dokonaniu powyższej przeróbki obraz jest lepszy, niebieska poświata zniknęła. Oczywiście zawsze lepiej podłączać się po RGB, ale nie wszystkie moje wyświetlacze mają SCART z RGB. Dlatego Composite bywa przydatne.

A z ciekawostek - z kabla audio 2xchinch-2xchinch (dobrej jakosci), jednej wtyczki mini-jack mono i wtyczki Din5 zrobiłem sobie bardzo zacny kabelek audio+video właśnie po Composite. Polecam.
Zielono mi... w temacie Spectrum. Ale zawsze się można douczyć.

Klaud

  • *****
  • Wiadomości: 1345
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • Pomógł: 30
  • Mordimer Madderdin
To jest bardzo dobra wiadomość i polecamy się (jako forum) na przyszłość.
KL
-----
Uzbierane ZXy i klony:
48K i2, i3B, i4A, i6, 48K+ i6, 128K i6U, +2B i2, +3 (napęd FDD do naprawy), Timex 2048 i5, Harlequin 48K iF, iG & Chrome 128K i3A.