Autor Wątek: Nowy Harlequin...  (Przeczytany 242328 razy)

damik

  • Rosin sniffer
  • *****
  • Wiadomości: 1555
  • Miejsce pobytu:
    Bytom
  • ZX Everyday
Odp: Nowy Harlequin...
« Odpowiedź #765 dnia: 2022.01.09, 18:10:12 »
Fajnie wyszło, pierwszy raz widzę taki kolor nasadek  :)

Czym robiłeś opisy na klawiszach?
Były już gotowe nadruki czy dawałeś naklejki lub grawerowałeś laserem albo frezarką cnc?
Wszystkiego po trochu: schwarz, mydło i powidło...

andy

  • *****
  • Wiadomości: 928
  • Miejsce pobytu:
    Kielce Wsch.
Odp: Nowy Harlequin...
« Odpowiedź #766 dnia: 2022.01.09, 20:11:28 »
wszystkie klawisze na 2 przyciskach się zacinają.. :(

Przerób shifty żeby z obu stron był symbol i caps. Przydatne. Kiedyś przerobiłem
od Mery, ale jest tylko 1 symbol, bo zabrakło miejsca.
pzdr
a.
POKE 35899,0  ZX 81, ZX Spectrum +, +2, Harlequin, ZX Max 48 & 128, Spider 48, Chrome 128, TC 2048, divIDE, CPC 464

KWF

  • *****
  • Wiadomości: 6241
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: Nowy Harlequin...
« Odpowiedź #767 dnia: 2022.01.09, 20:49:01 »
Porównując HQ48 do HQ128, niby te same konstrukcje, ale jak się patrzy w oscyloskop, to jakby zupełnie inne."

A czy w obu przypadkach używałeś  U13 - U16 tego samego producenta i z tej samej partii?

Generator zegara 14MHz w 48K a 14,1875MHz 128K to dwie różne konstrukcje. W 128K jest dzielnik na przerzutniku 74HC74 i jeśli on jest chińską malowanką to może nie wyrabiać się przy 28MHz na wejściu.
KL
-----
R Tape loading error 0:1

z80pio

  • *
  • Wiadomości: 7
  • Miejsce pobytu:
    PL, Kraków, okolice Buska
Odp: Nowy Harlequin...
« Odpowiedź #768 dnia: 2022.01.10, 08:13:40 »
Ta klawiatura to takie tymczasowe rozwiązanie wystrugane w pół niedzieli, płytka robiona mazakiem i ręczną wiertareczką, więc nie jest to za równe, klawisze to Keycaps do Cherry MX, pełno tego u Chińczyków w przeróżnych wzorach i kolorach, a i w Polsce da się kupić, one są przeznaczone do podświetlania, więc literki na nich są przezroczyste, same przyciski też się da kupić, ale najtaniej wychodzi kupić używaną klawiaturę mechaniczną i wykorzystać jako dawcę, i docelowo tak chcę zrobić, tylko muszę przemyśleć zarówno rozkład klawiszy jak i sposób montażu całości..

Tonick

  • *
  • Wiadomości: 2
  • Miejsce pobytu:
    Katowice
Odp: Nowy Harlequin...
« Odpowiedź #769 dnia: 2022.01.14, 14:24:59 »
Witam.
Mam problem z klonem Zx spectrum 48 harlequin rev g, mianowicie na ekranie są spore zakłócenia w postaci poziomych lini, ponadto w napisie "spectrum"  litera "m" jest nieczytelna
 (film https://youtu.be/NqROK4mgPQQ),
 zakłócenia występują bez względu na sposób podłączenia do TV czy to przez Composite czy RGB-SCART oraz bez względu na użyty TV LCD czy też CRT. Na chwilę obecną sprawdziłem linie RGB czy to nie któraś z nich tak sieje, odłączając każdą po kolei z wtyczki scart - każdy kolor sieje tak samo.
Czy macie jakieś pomysły na rozwiązanie problemu?
Proszę o pomoc.

KWF

  • *****
  • Wiadomości: 6241
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: Nowy Harlequin...
« Odpowiedź #770 dnia: 2022.01.14, 16:04:58 »
Ta literka "m" tak wygląda, taki font tyle. A reszta, to pewnie syfy od zasilania. Czym zasilasz tego HQ?

Wyłącz wszystkie pogarszacze obrazu w tym LCD, szczególnie podbijanie częstotliwości, filtry krawędziowe, automatyczne wyostrzanie obrazu.
KL
-----
R Tape loading error 0:1

Tonick

  • *
  • Wiadomości: 2
  • Miejsce pobytu:
    Katowice
Odp: Nowy Harlequin...
« Odpowiedź #771 dnia: 2022.01.14, 18:23:49 »
Próbowałem dwóch różnych zasilaczy impulsowy 12v oraz transformatorowy 9v.
Mój monitoro-telewizor nie ma takich bajerów, ponadto na starym bańkowym TV obraz był taki sam a dodatkowo jeszcze mrygał.
Ciekawe czy opmogłaby przeróbka na SVHS?

z80pio

  • *
  • Wiadomości: 7
  • Miejsce pobytu:
    PL, Kraków, okolice Buska
Odp: Nowy Harlequin...
« Odpowiedź #772 dnia: 2022.01.21, 20:26:45 »
Hej.
A mnie HQ48 w końcu ruszył.. Jak już przelutowałem wszystkie podstawki, to zacząłem sprawdzać, czy nie ma zwarć między sąsiednimi pinami na scalakach, no i się znalazło, ale było chamskie, bo 2mm kawałek jakiegoś drutu przykleił się do nóżek podstawki precyzyjnej od strony elementów, praktycznie nie do wypatrzenia..
A co do tego
... na ekranie są spore zakłócenia w postaci poziomych lini...
też obstawiam, że to śmieci z zasilania, choć trochę podobne zakłócenia miałem, jak zapomniałem o jednej zworce pal/ntsc..
Ja zacząłbym od zrobienia nowego kabla, kable analogowe potrafią psuć sygnał, zwłaszcza nieekranowane. Kupiłbym gotowy zalewany kabel mini Din 8, przeciął i dolutował wtyczki euro i zobaczył czy coś to dało. Jeśli nic, to w kolejnych krokach:
-zasiliłbym ustrojstwo z akumulatora
-wymienił elektrolity filtrujące
-dołożył 100nF na każdy scalak, najlepiej ceramiczne
-wylutował przetwornice i testowo zastosował stabilizator liniowy
-odłączył część analogową na płytce (Q1..Q4), poskładał na boku drugą na tranzystorach i rezystorach z innej  partii, i podpiął do U30..32 Do testów wystarczy jeden z kolorów i synchronizacja
-zaklął, wypił parę piw i poszedł spać, następnego dnia lepiej się myśli.. ;)

tomi

  • **
  • Wiadomości: 80
  • Miejsce pobytu:
    Poznań
Odp: Nowy Harlequin...
« Odpowiedź #773 dnia: 2022.01.26, 00:46:00 »

Niestety po ok 10 minutach (CPU jest wyraźnie ciepły) pojawiają się zniekształcenia ekranu (nie występują gdy divMMC jest wyjęty).Problem może dotyczyć samego CPU (ma uszkodzenie NMI), jednak wydaje mi się, że bardziej dotyczy problemów z częstotliwością (w końcu CPU 6,8,10 MHz też powinny działać).
Myślę, że będę musiał poeksperymentować z podmianką układu U13 (74HCU04) lub samym rezonatorem Y1 (28,375MHz) o ile uda mi się go zdobyć.


Problem zniekształceń udało się rozwiązać.
Sama szybka podmianka CPU nie rozwiązała problemu (po kilku sekundach zniekształcenia wracały - inny CPU NMOS - zimny). Również podmianka Y1 na innej firmy kompletnie nic nie wniosła. Podmianka U10 na inny egzemplarz (też Texas Instruments, ale z innej dostawy) też nie przyniosła poprawy.

Skorzystałem z udostępnianych przez z80pio (dziękuję :) ) układów philips'a.
-  jak poprzednio wymieniłem układy U13 i u14-16 na philipsa, ale tym razem wszystkie jednocześnie czyli i u13 (74HC04N) i u14, 15, 16 (74HC161N). Tu uzyskałem obraz jednak nadal przy stosowaniu procesora CMOS nie udało mi się zmusić do współpracy ZXHQ128 z divMMC (pozostały też pozostałe problemy przy wybranych demach -  błędne kolory, zakłócenia dźwięku i brak uruchomienia).
Jednak tym razem testowałem wpływ zmiany na występujące po dłuższej pracy zakłócenia obrazu przy korzystaniu z procesora NMOS. I okazało się, że przy jednym ustawieniu u14 - u16  problem zniknął :) ( powtarzane 3 krotnie testy odtwarzania dem powyżej 8 godzin - wcześniej problem występował po ok 30 - 40 minutach)
Zmiana miejscami tych układów U14 - 16 powoduje albo brak obrazu, albo powrót zakłóceń. Czyli jest poprawa, z CPU NMOS działa praktycznie poprawnie (wyjątkiem kilka dem które nie startują lub przerywają działanie resetem - te same dema działają na ZX Spectrum 128+2 i te co mogą również na ZXHQ48).  Prawdopodobnie układy pracują blisko swoich wartości granicznych i stąd zamiana ich miejscami powoduje problemy.
Aktualna działająca konfiguracja sprzętowa na zdjęciu.

Problem nie do końca poprawnego działania (timing ? ) z częścią procesorów występuje nie tylko u mnie, tu na forum zasygnalizował go tapy, a zauważył go również Ben z BD:
https://www.bytedelight.com/?page_id=3457
"After writing this article I found out that the slight differences were actually caused by the CPU used.
It seems that there are small timing differences between Z80 CPUs"

Po konsultacji z 8bitpolo będę chciał przetestować jeszcze, czy zmiana na zalecane przez Superfo układy 74HC161 firmy ST Microelectronics (mają parametr f max ponad dwukrotnie wyższy od używanych przeze mnie Texas Ins. czy Philipsów)  lub inne o nie gorszych parametrach rozwiąże problem współpracy CPU CMOS z divMMC.
Jest jednak problem z ich zakupem, gdyby ktoś miał na zbyciu proszę o info.

Prosiłbym również kolegów posiadających ZXHQ128 o sprawdzenie w wolnej chwili jak działają z demami:
- Smash Megademo (1996) ; po wybraniu intro działa pierwsza część, podczas ładowania drugiej (po przerywniku) mam reset
- MDA Demo (19xx) ; u mnie przy CPU CMOS w drugiej części błędny biały kolor połowy ramki i zakłócenia dźwięku. Z NMOS CPU ok
- Lyra II Megademo ; zatrzymuje się na kręcącej butelce (chyba 3 część)

« Ostatnia zmiana: 2022.01.26, 01:14:44 wysłana przez tomi »

KWF

  • *****
  • Wiadomości: 6241
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: Nowy Harlequin...
« Odpowiedź #774 dnia: 2022.01.26, 07:25:22 »
"[..] zmiana na zalecane przez Superfo układy 74HC161 firmy ST Microelectronics (mają parametr f max ponad dwukrotnie wyższy od używanych przeze mnie Texas Ins. czy Philipsów) [..]"

Prościej poszukać układów z serii AC. Tylko coś mi nie gra, ponieważ w HQ128 zegar 28MHz z groszem nie idzie wprost na U14-U16. Do dzielnika ("Horizontal Counter" złożonego z U14-U16) podawany jest zegar podzielony na pół (14MHz z groszem) przez przerzutnik 74HC74 (U19). Może to on nie wyrabia się i jego należałoby podmienić na serię AC.

EDYTA:
Pytanie z serii pomocniczych: O jakim czasie dostępu masz dolny RAM (U8)?

EDYTA 2:
Już dojrzałem na Twoim zdjęciu: UM61512AK-12 .. 12ns, moim zdaniem za szybko, ponieważ multipleksery U40 i U41 (74HC257) nie wyrabiają się z przełączaniem adresów, zanim pojawią się stroby /OE, /CS, /WE.
« Ostatnia zmiana: 2022.01.26, 08:37:42 wysłana przez KWF »
KL
-----
R Tape loading error 0:1

tomi

  • **
  • Wiadomości: 80
  • Miejsce pobytu:
    Poznań
Odp: Nowy Harlequin...
« Odpowiedź #775 dnia: 2022.01.26, 15:18:47 »
"Tylko coś mi nie gra, ponieważ w HQ128 zegar 28MHz z groszem nie idzie wprost na U14-U16. Do dzielnika ("Horizontal Counter" złożonego z U14-U16) podawany jest zegar podzielony na pół (14MHz z groszem) przez przerzutnik 74HC74 (U19). "

Pytanie z serii pomocniczych: O jakim czasie dostępu masz dolny RAM (U8)?

Dzięki Klaudiusz za pochylenie się nad tematem  :).
Już uzupełniam odp.

Na zdjęciu słabo widać (na samej kostce zresztą też).
RAM (U8 i U3) to UM61512AK-15  15ns

Jeśli chodzi o schemat, operujesz raczej na issue 3H (zmieniony też jest R15). Mój HQ128 to issue 2D i tu sygnał z U13 idzie wprost na U14-16 patrz schemat:

https://trastero.speccy.org/cosas/JL/Superfo-Harlequin-128K/Documentacion/HARLEQUIN_128_Issue_2D.zip

Co nie zmienia faktu, że przyczyna problemu może leżeć nie tylko lub zupełnie gdzie indziej niż na u14-16.


KWF

  • *****
  • Wiadomości: 6241
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: Nowy Harlequin...
« Odpowiedź #776 dnia: 2022.01.26, 15:34:14 »
Mea culpa, masz rację co do zegara. W takim razie poszukaj 74AC161, można je jeszcze kupić.

15ns na pamięć obrazu jest zbyt szybko, ponieważ multipleksery 74HC257 mogą nie zdążyć z pełnym ustawieniem adresów. Stąd możesz mieć śmieci na ekranie lub nawet niestabilne działanie całości. Jeśli masz pod ręką jakąś pamięć statyczną (nie cache) to podmień U8 na nią.

Swoją drogą przy okazji innego klona Don uczulił mnie na, że super szybki SRAM nie działa poprawie jako pamięć obrazu w HQ128.
KL
-----
R Tape loading error 0:1