Autor Wątek: ZX Spectrum 128K +2B Z70833 issue 4 - widzi 16KB RAM  (Przeczytany 581 razy)

m0b

  • *****
  • Wiadomości: 727
  • Miejsce pobytu:
    Warszawa
  • ***** ***
ZX Spectrum 128K +2B Z70833 issue 4 - widzi 16KB RAM
« dnia: 2022.10.24, 00:07:56 »
Hej

Wpadł na moje biurko czarny ZX Spectrum 128K +2B. Przyjechał bez części RAM (IC3, IC4), a układy IC5, IC6 grzały tak, że jajka można było smażyć. CPU też okazał się martwy. Po włożeniu sprawnego CPU wystartował z zewnętrznym ROMem diagnostycznym. Po obsadzeniu IC3, IC4 (NEC D41464C-10 - takie miałem pod ręką), pokazał normalny obraz, jednak ROM diagnostyczny nie znalazł górnego RAM (czyli działał jako 16K). Przy okazji zauważyłem, że 40077 grzeje się jak diabli, ale komputer działa, sprawdziłem np. klawiaturę, dźwięk itp. Sprawdzając tak trochę wyrywkowo to co idzie do 40077 i porównując z drugą taką samą płytą, która przez przypadek również trafiła na moje biurko :) zauważyłem, że C52 (jest na linii /CAS, czyli 16 noga układów IC5, IC6) jest zwarty do masy. Kondensator jednak okazał się sprawny, więc wygląda na to, że zwarcie do masy ma ta linia 40077, bo nic po drodze innego nie widzę. Czy to padnięty układ, czy coś z dopiętych do niego rzeczy może powodować taki efekt? Wydaje mi się, że nic innego się nie grzeje.
« Ostatnia zmiana: 2022.10.24, 00:35:02 wysłana przez m0b »

damik

  • Fresh rosin sniffer ;)
  • *****
  • Wiadomości: 2021
  • Miejsce pobytu:
    Bytom, czasem Bielsko-Biała oraz okolice
  • ZX Everyday
Odp: ZX Spectrum 128K +2B issue 4 - widzi 16KB RAM
« Odpowiedź #1 dnia: 2022.10.24, 00:37:10 »
Przetnij delikatnie ścieżkę sygnału /CAS idącą od układu 40077 i wszystko stanie się jasne ;)
Wszystkiego po trochu: Schwarz, mydło i powidło... konsole, stare i nowsze komputery oraz akcesoria i duperele.

KWF

  • *****
  • Wiadomości: 6550
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: ZX Spectrum 128K +2B Z70833 issue 4 - widzi 16KB RAM
« Odpowiedź #2 dnia: 2022.10.24, 04:54:50 »
... Przyjechał bez części RAM (IC3, IC4), a układy IC5, IC6 grzały tak, że jajka można było smażyć. CPU też okazał się martwy. Po włożeniu sprawnego CPU wystartował z zewnętrznym ROMem diagnostycznym. Po obsadzeniu IC3, IC4 (NEC D41464C-10 - takie miałem pod ręką), pokazał normalny obraz, jednak ROM diagnostyczny nie znalazł górnego RAM (czyli działał jako 16K).

Zostawiłeś grzejące się układy IC5 i IC6? Czy testowałeś płytę tylko włożonymi IC3 i IC4?

Przy okazji zauważyłem, że 40077 grzeje się jak diabli, ale komputer działa, [...] zauważyłem, że C52 (jest na linii /CAS, czyli 16 noga układów IC5, IC6) jest zwarty do masy. Kondensator jednak okazał się sprawny, więc wygląda na to, że zwarcie do masy ma ta linia 40077, bo nic po drodze innego nie widzę. Czy to padnięty układ, czy coś z dopiętych do niego rzeczy może powodować taki efekt? Wydaje mi się, że nic innego się nie grzeje.

Wykluczyłeś uszkodzenie układów pamięci IC5 lub IC6? Pomiary robiłeś po wymontowaniu IC5 i IC6? Wsadź je na próbę za IC3/IC4 i zobacz czy komputer ożyje.
KWF
-----
R Tape loading error 0:1
Moje zabawki: https://github.com/McKlaud76

m0b

  • *****
  • Wiadomości: 727
  • Miejsce pobytu:
    Warszawa
  • ***** ***
Odp: ZX Spectrum 128K +2B Z70833 issue 4 - widzi 16KB RAM
« Odpowiedź #3 dnia: 2022.10.24, 08:50:50 »
Układy grzejące się wypadły - one są martwe, w pozycji IC3, IC4 też nie działają. Płytę testowałem zarówno z włożonymi tylko nowymi IC3, IC4, jak i z pełną obsadą. Efekt zawsze ten sam, czyli test 16KB pamięci i komunikat "No upper RAM detected" (DiagROM 1.59). Dodam, że na 5V jest spadek napięcia do 4.6V - stąd tyle ciepełka oddaje 40077.

Z tym cięciem ścieżek, to jakoś nie mam śmiałości :) Ale może spróbuję odlutować (podnieść) nogę 40077. Na razie rozważam, czy mam takie umiejętności ;)

KWF

  • *****
  • Wiadomości: 6550
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: ZX Spectrum 128K +2B Z70833 issue 4 - widzi 16KB RAM
« Odpowiedź #4 dnia: 2022.10.24, 11:29:52 »
Próbowałeś dedykowane testy pamięci dla 128K z tego ROMu diagnostycznego? Jeśli tak, to czy banki 4, 5, 6 i 7 są testowane poprawnie?

Próbowałeś odpalać maszynę z tymi szybszymi pamięciami (100ns) ale bez kondensatora C52 na linii /CAS (/CS)? Nie pamiętam o jakim czasie dostępu są fabryczne pamięci w +2A/+3 ale chyba max. 150 ns.

Osobiście wolałbym odciąć ścieżkę, niż probował odlutować jeden pin od QFP. Ścieżkę zawsze możesz połatać, a jeśli przypadkowo urwiesz nogę od GA to pozamiatane.
KWF
-----
R Tape loading error 0:1
Moje zabawki: https://github.com/McKlaud76

m0b

  • *****
  • Wiadomości: 727
  • Miejsce pobytu:
    Warszawa
  • ***** ***
Odp: ZX Spectrum 128K +2B Z70833 issue 4 - widzi 16KB RAM
« Odpowiedź #5 dnia: 2022.10.24, 14:29:28 »
Z kondensatorem, czy bez efekt był ten sam.
Testu pamięci 128K nie przechodzi - wszystkie bity zgłasza jako złe.