Autor Wątek: ZX SPECTRUM ISSUE 3 - pionowe pasy  (Przeczytany 3936 razy)

jackfinch

  • ****
  • Wiadomości: 399
  • Miejsce pobytu:
    uk
ZX SPECTRUM ISSUE 3 - pionowe pasy
« dnia: 2020.12.21, 16:06:43 »
Witam
ZX48 leżał sobie dość długo ze zdjętą górną pokrywą. Wczoraj w końcu zebrałem się do skręcenia obudowy i po podłączeniu do monitora taki oto obraz jak w załączniku.
Pomiary dolnego ramu (4116)
1. -4.78V
8. 11.98V
9. 4.94V
Grzeje się tylko ULA (6C001E-6)
Jakieś sugestie.

Pozdrawiam

Boyo

  • *****
  • Wiadomości: 718
  • Miejsce pobytu:
    Warszawa
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #1 dnia: 2020.12.21, 16:32:32 »
Model suicide-ula :(
ZX81 / 2x ZX Spectrum 48kB / 3x ZX Spectrum+ 48kB / Inves Spectrum+ / ZX Spectrum+ 128kB / 2x ZX Spectrum +2 / ZX Spectrum +2A Action Pack / ZX Spectrum +3 / Didaktik Gama / TC 2048 / 2x JustSpeccy 128K
A500 2,5MB RAM Gotek HxC / A1200 Blizzard 1220/4+ADD4

KWF

  • *****
  • Wiadomości: 6405
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #2 dnia: 2020.12.21, 16:51:03 »
Zawartość ROMu wyparowała.
KWF
-----
R Tape loading error 0:1

jackfinch

  • ****
  • Wiadomości: 399
  • Miejsce pobytu:
    uk
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #3 dnia: 2020.12.21, 17:01:19 »
Chyba masz rację, akurat podobny objaw widziałem na tej stronie z taką samą diagnozą jaką ty wydałeś.
https://stardot.org.uk/forums/viewtopic.php?t=10127#p121372

ps. 27256 EPROM będzie pasował na wymianę?
« Ostatnia zmiana: 2020.12.21, 17:09:46 wysłana przez jackfinch »

KWF

  • *****
  • Wiadomości: 6405
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
KWF
-----
R Tape loading error 0:1

jackfinch

  • ****
  • Wiadomości: 399
  • Miejsce pobytu:
    uk
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #5 dnia: 2020.12.21, 19:22:10 »
Dzięki, jeżeli to faktycznie będzie ROM, to mam 1 sztukę 27256 i będę w stanie to wymienić.

Pozdrawiam

jackfinch

  • ****
  • Wiadomości: 399
  • Miejsce pobytu:
    uk
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #6 dnia: 2020.12.23, 12:25:22 »
Klaud czytałem w jednym z tych linków co mi podałeś, że w EPROMa zaszyłeś dwa obrazy, jeden to ROM testowy a drugi niemodyfikowany ROM od ZX48K. Możesz go tutaj wrzucić, bo po wymianie dysku w laptopie ciężko mi coś znaleźć. Wylutowanie tego ROM-u to jaką masakra, wczoraj zacząłem wylutowywać, ale musiałem dać sobie spokój z braku czasu. O ile od dołu udało mi się odessać cynę, to nóżki romu na górnej warstwie sprężynują i przywierają do przelotek gdzie są pewne ilości cyny, którą ciężko odessać.

Pozdrawiam

KWF

  • *****
  • Wiadomości: 6405
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #7 dnia: 2020.12.23, 12:50:27 »
Odetnij stary układ i wyjmij nóżki jedna po drugiej, skoro i tak uszkodzony. Po co męczysz się. Swoją drogą, zawsze pomaga przelutowanie starych lutów nową cyną przed odssysaniem. Cyną z ołowiem, a nie bezołowiowym czymś.

ROM testowy jest też na stronie Phila: http://blog.retroleum.co.uk/electronics-articles/a-diagnostic-rom-image-for-the-zx-spectrum/
KWF
-----
R Tape loading error 0:1

jackfinch

  • ****
  • Wiadomości: 399
  • Miejsce pobytu:
    uk
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #8 dnia: 2021.05.12, 19:45:34 »
Znalazłem chwile czasu w niedzielę i w końcu wylutowałem stary rom. Wlutowałem podstawkę, zrobiłem zworę między 1 i 28 nóżką eproma, rozlutowałem punkty H i N i wlutowałem 2 x 1N4148 i 10k rezystor do masy, a na koniec 1k rezystor do masy (eprom 27c256)  żeby startował z banku 0. Epromu nowego nie robiłem tylko wyciągnąłem z ZX MAX 48. Po włączeniu do prądu pojawia się ramka na ekranie a po sekundzie logo spectrum i potem kursor. Ale później już dzieje się czarna magia. Wskakują losowe kolorowe ekrany. Na razie nie zrobiłem zdjęć. Podpiąłem się do banku 1, gdzie jest diag rom w wersji 1.31 jak wynika z ekranu startowego. Albo ja coś schrzaniłem albo coś się popsuło. Narazie z braku czasu tyle. Załączam zdjęcia.

jackfinch

  • ****
  • Wiadomości: 399
  • Miejsce pobytu:
    uk
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #9 dnia: 2021.12.08, 22:03:09 »
Witam
Ciąg dalszy naprawy, wymieniłem wszystkie 74157 i niestety jest to samo. Wymienione 74157 sprawdzone na tl866 i pokazuje że są sprawne. Na romie diagnostycznym przechodzi test dolnego ramu i zawiesza się na ekranie czwartym czyli starcie testowania górnego ramu. Zmierzyłem napięcia na na ULA i na na 13 pinie mam 3.44V, a na 14 pinie mam 4.90. Według tego co znalazłem to pin 13 to VCC logic 5V (5V logic supply), pin 14 to VCC IO (5V analogue and interface supply). Po wyjęciu ULA z podstawki na tych 2 pinach jest 4.94V, czy tak ma być? Czy raczej ULA też jest uszkodzona? Jakieś sugestie i pomysły?
Pozdrawiam

trojacek

  • *****
  • Wiadomości: 6420
  • Miejsce pobytu:
    Warszawa
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #10 dnia: 2021.12.08, 22:12:01 »
R34 jest OK?

jackfinch

  • ****
  • Wiadomości: 399
  • Miejsce pobytu:
    uk
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #11 dnia: 2021.12.09, 00:33:49 »
Po zmierzeniu rezystancji bez wylutowywania ma 15 ohm.

Grefkow

  • CharlesNicOB
  • ***
  • Wiadomości: 100
  • Miejsce pobytu:
    Lodz
Odp: ZX SPECTRUM ISSUE 3 - pionowe pasy
« Odpowiedź #12 dnia: 2022.04.15, 14:41:43 »
ULA i na na 13 pinie mam 3.44V, a na 14 pinie mam 4.90.
U mnie jest dokładnie tak samo ale wszystko działa tylko mam Jailbars ale nie wstawiałem jeszcze C5-C8 większych kondensatorów.