Autor Wątek: Uszkodzenia ZX81  (Przeczytany 52438 razy)

pear

  • *****
  • Wiadomości: 5339
  • Miejsce pobytu:
    Będzin
  • Z80 only
Odp: uszkodzonia zx81
« Odpowiedź #75 dnia: 2016.03.18, 10:35:22 »
Też mam taki plan, ale wczoraj już miałem dość niepowodzeń ;)
ZX/Enterprise/CPC/Robotron/C128D

martin381

  • *****
  • Wiadomości: 1201
  • Miejsce pobytu:
    JAROCIN
  • Gdzie jestem.....dokąd zmierzam....dokąd
Odp: uszkodzonia zx81
« Odpowiedź #76 dnia: 2016.03.18, 10:40:21 »
Kolektor do +5v
Emiter rezystor 100 Ohm do masy i wyjście bez kondensatora.
Baza do niebieskiej PR-ki (oporowo 2k) potem dioda i pin5 scakala lm1881
Do bazy tego tranzystora dochodzi też bezpośrednio sygnał video z ULA
Spectrusie  i akcesoria(rożne  , przechodnie , nie tylko komputerki) , miałem w rękach ISSUE 1 , Harlequin , poszukuję spektrusia którego zmajstrowałem 28 lat temu , AX81 , ZXUNO , ICOM IC7000  call sign SQ3PLR

pear

  • *****
  • Wiadomości: 5339
  • Miejsce pobytu:
    Będzin
  • Z80 only
Odp: uszkodzonia zx81
« Odpowiedź #77 dnia: 2016.03.18, 10:44:13 »
Dzięki :)
ZX/Enterprise/CPC/Robotron/C128D

martin381

  • *****
  • Wiadomości: 1201
  • Miejsce pobytu:
    JAROCIN
  • Gdzie jestem.....dokąd zmierzam....dokąd
Odp: uszkodzonia zx81
« Odpowiedź #78 dnia: 2016.03.18, 10:53:11 »
A tranzystor to BC546 bo na schematach zawsze BF199 ale chyba nie miałem i taki poszedł
Spectrusie  i akcesoria(rożne  , przechodnie , nie tylko komputerki) , miałem w rękach ISSUE 1 , Harlequin , poszukuję spektrusia którego zmajstrowałem 28 lat temu , AX81 , ZXUNO , ICOM IC7000  call sign SQ3PLR

trojacek

  • *****
  • Wiadomości: 6448
  • Miejsce pobytu:
    Warszawa
Odp: uszkodzonia zx81
« Odpowiedź #79 dnia: 2016.03.18, 10:59:23 »
Przy sygnale  < 5 MHz nie ma to i tak znaczenia ;)

martin381

  • *****
  • Wiadomości: 1201
  • Miejsce pobytu:
    JAROCIN
  • Gdzie jestem.....dokąd zmierzam....dokąd
Odp: uszkodzonia zx81
« Odpowiedź #80 dnia: 2016.03.18, 11:14:42 »
Tak zapas jest wystarczający :)
Spectrusie  i akcesoria(rożne  , przechodnie , nie tylko komputerki) , miałem w rękach ISSUE 1 , Harlequin , poszukuję spektrusia którego zmajstrowałem 28 lat temu , AX81 , ZXUNO , ICOM IC7000  call sign SQ3PLR

pear

  • *****
  • Wiadomości: 5339
  • Miejsce pobytu:
    Będzin
  • Z80 only
Odp: uszkodzonia zx81
« Odpowiedź #81 dnia: 2016.04.03, 18:07:52 »
Przećwiczyłem dziś różne konfiguracje podrasowania sygnału Composite Video z ZX81.
Testowałem z ULA 2C210E, czyli teoretycznie tą lepszą, ale i tak LM1881 nie daje rady poprawnie wygenerować sygnału wideo.
Co prawda jest lepiej, nawet dużo lepiej, ale postawiłem sobie poprzeczkę dość wysoko.
Chcę, żeby moja wersja dawała pełny, prawidłowy sygnał wideo, taki żeby nawet na kiepskim LCD dało się go zobaczyć.
Na razie jest idealnie tylko na CRT, z regulacją poziomu jasności. Na LCD obraz jest czysty, ale synchronizacja jest niestabilna i zrywa.

Przy okazji zepsułem sobie folię klawiatury, więc póki co projekt ZX81 Composite odkładam na półkę.
Jest jeszcze trochę do zrobienia. Może jak będzie nieco cieplej ;D
ZX/Enterprise/CPC/Robotron/C128D

hsimpson

  • *****
  • Wiadomości: 697
  • Miejsce pobytu:
    Warszawa
Odp: uszkodzonia zx81
« Odpowiedź #82 dnia: 2016.04.03, 18:53:44 »
Pocieszające jest to, że pogoda znacznie się poprawiła i będzie dużo ciepłej ;).

jackfinch

  • ****
  • Wiadomości: 400
  • Miejsce pobytu:
    uk
Odp: uszkodzonia zx81
« Odpowiedź #83 dnia: 2016.08.27, 01:07:18 »
Witam

Czy taki tranzystor C945 będzie się nadawał na video-mod?

Pozdrawiam

zipp

  • ****
  • Wiadomości: 329
  • Miejsce pobytu:
    Małopolska
Odp: uszkodzonia zx81
« Odpowiedź #84 dnia: 2016.10.02, 19:52:10 »
Zrobiłem rasowanie sygnału wideo wg tego schematu
http://zx.zigg.net/misc-projects/
Działa bardzo dobrze, a jedynym odstępstwem było zmniejszenie kondensatora C3 do wartości 470pF.
Przy 820pF obcinało trochę lewą stronę obrazu. Testowane na małym badziewnym monitorku LCD.

KWF

  • Moderator
  • *****
  • Wiadomości: 6443
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: uszkodzonia zx81
« Odpowiedź #85 dnia: 2018.01.20, 23:27:42 »
Zrobiłem rasowanie sygnału wideo wg tego schematu
http://zx.zigg.net/misc-projects/
Działa bardzo dobrze, a jedynym odstępstwem było zmniejszenie kondensatora C3 do wartości 470pF.
Przy 820pF obcinało trochę lewą stronę obrazu. Testowane na małym badziewnym monitorku LCD.

Też podrasowałem sobie Zeddiego wg. tego schematu, ale z lekkimi modyfikacjami:
1. R1 zamieniłem na 4.7kOhma
2. w szereg z R1 dodałem potencjometr 10kOhma
3. C3 zmniejszyłem do 680pF (w sumie trzeba go dobrać eksperymentalnie)
4. równolegle z C3 dodałem trymer 6-70pF

Aha, zamiast tranzystorów 2N2222 wsadziłem 2N3904, bo takie miałem pod ręką.



Na moje niewprawne oko, układ działa dużo lepiej, niż oczekiwałem. Sprawdzałem na hiper-super 20" LCD Sony'ego oraz na monitorku LCD do kamery cofania. Dema "25thanni" oraz "HelloWorld" dają niezłe wrażenia wizualne.
KWF
-----
R Tape loading error 0:1
Moje zabawki: https://github.com/McKlaud76

ediman

  • **
  • Wiadomości: 66
  • Miejsce pobytu:
    Poznań
Odp: uszkodzonia zx81
« Odpowiedź #86 dnia: 2018.06.05, 22:31:47 »
Pytanko do mistrzów lutownicy. Znalazł by się ktoś kto zrobiłby mi (oczywiście odpłatnie) taki composit do Zedda. Dodatkowo padło mi rozszerzenie 16k to może dało by się je przy okazji naprawić. http://www.speccy.pl/forum/index.php?topic=2563.msg66019#msg66019

KWF

  • Moderator
  • *****
  • Wiadomości: 6443
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: uszkodzonia zx81
« Odpowiedź #87 dnia: 2018.06.05, 22:51:11 »
Najprościej zrobić kompozyt na NE555, pokazany na foto 2 posty wyżej. Sprawdziłem z 3 wersjami ULA. A do tego wymienić RAM na 62256 + 3 kawałki kynaru i rezystor 10k.

Mod do 16KB opisałem na wiki: http://speccy.pl/wiki/index.php?title=ZX81_16K

Mógłbym zrobić naprawę, ale z podmiana płyty głównej. Ty mi wyślesz swoją, a ja wyślę do Ciebie inna sprawna ze zmianami jakie chcesz. Reszta na PW.
« Ostatnia zmiana: 2018.06.05, 23:32:57 wysłana przez Klaud »
KWF
-----
R Tape loading error 0:1
Moje zabawki: https://github.com/McKlaud76

PABB

  • *****
  • Wiadomości: 1090
  • Miejsce pobytu:
    Bielsko-Biała
Odp: Uszkodzenia ZX81
« Odpowiedź #88 dnia: 2022.01.22, 14:26:24 »
wykopalisko_mode ON :)

Panowie - szybkie pytanie. Wykorzystując moduł autorstwa Klaudiusza dodałem jednemu z kolegów wyjście compositeo do ZX81.

Obraz jest OK - jednak sam proces "bootowania" po włączeniu zasilania wygląda odrobinę inaczej, niż przy innych maszynach (https://youtu.be/4WBivtiZCFg). W uproszczeniu:
- power on
- zakłócenia przez kilka sekund
- obraz jak żyleta

Zastanawiam się czy to cecha ZX81 z tym modem, czy monitor desperacko próbuje ogarnąć sygnał, który do niego dochodzi (stawiam na to drugie - a chwilowo nie mam innego monitora do weryfikacji).

Co o tym sądzicie?


KWF

  • Moderator
  • *****
  • Wiadomości: 6443
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • "I co ja robię tu, u-u, co Ty tutaj robisz ..."
    • Insta do lasownia
Odp: Uszkodzenia ZX81
« Odpowiedź #89 dnia: 2022.01.22, 14:48:20 »
Zrywa synchro i coś nie tak z poziomem jasności. Masz tam potencjometr i trymer do delikatnego podregulowania, ale cudów nie oczekuj. No i która wersja ULA'i?

Spróbuj wczytać jakieś demko, najlepiej z hi-res i zobacz czy nadal masz poprawny obraz.
KWF
-----
R Tape loading error 0:1
Moje zabawki: https://github.com/McKlaud76