Autor Wątek: 128k - ciekawy problem  (Przeczytany 324 razy)

PABB

  • *****
  • Wiadomości: 1019
  • Miejsce pobytu:
    Bielsko-Biała
128k - ciekawy problem
« dnia: 2021.01.26, 21:12:57 »
... właśnie przygotowałem do wysyłki 128k jednego z kolegów z forum. Trafił do mnie z ciekawą przypadłością - uruchamiał się poprawnie, podstawowe testy pamięci z ROMów diagnostycznych przechodził poprawnie - ale kiedy zaczynał wykonywać testy charakterystyczne dla 128, to wyrzucał błędy wskazujące to na układ PCF, to na kości IC15/IC16.

W związku z tym, że miałem kilka płytek do zamiennika PCF1306 i udało się kupić potrzebne scalaki posklejałem jedną sztukę i wrzuciłem do pacjenta. Uruchomił się poprawnie - sukces. Podpiąłem klawiaturę - przykręciłem płytę - włączam i... dupa. Znowu nie przechodzi testów. Wyciągnąłem płytę na biurko - podłączam i... gościu ożył i pręży muskuły...

Oszczędzę Wam opisu zabawy z miernikiem i - jak to mówiła moja babcia - do brzegu. Ktoś wcześniej wsadził wszystkie kości pamięci w podstawki. Całkiem jednak mocno podczas tej operacji grzał laminat (aż ma drobne odbarwienia przy pinach kości pamięci) i nie zauważył, że drobnemu uszkodzeniu uległa ściezka pomiędzy nóżką 13 kości IC15 (A6) a przelotką prowadzącą sygnał do pinu 27 układu PCF. W zależności od tego pod jakim kątem przyłożyłem sondę - miałem przejście lub nie (podobnie sytuacja miała się w przypadku wsadzonej kości). Nie chciałem ponownie wylutowywać podstawki więc zrobiłem mikrozworkę od dolnej strony i Toastrack powrócił na ten łez padół niezależnie od tego jakbym nie wyginał PCB :)

Reasumując - ciekawe podwójne uszkodzenie (zarówno PCF jak i walnięta ścieżka) dające bardzo podobne symptomy. A dla mnie nauczka - jak są podstawki w miejscach w których ich oryginalnie nie było, to warto nimi lekko poruszać podczas pomiaru ciągłości :P