Autor Wątek: Montujemy JS128  (Przeczytany 19874 razy)

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #285 dnia: 2019.04.02, 21:49:28 »
Stara zasada mówi - coś nie działa sprawdź luty. Wziąłem dużą lupkę od sąsiada i przejrzałem jeszcze raz całą płytkę. Patrzyłem głównie na pady na BC547, lecz podejrzanie wyglądała mi jedna nóżka na Q18. Lutownica - 5 sekund pracy i....... działa :-)))  Na razie ZX zgłosił się ze standardowym logiem, po drodze mignęła mi jednak plansza MMC. No nie mam jeszcze skończonej klawiatury i przygotowanej karty SD - może jutro mi się uda wszystko sklecić. Obraz jest, chyba nie zasnę z wrażenia. Panowie, serdeczne dzięki za zaangażowanie, sugestie i pomoc.

zaxon

  • *****
  • Wiadomości: 4059
Odp: Montujemy JS128
« Odpowiedź #286 dnia: 2019.04.02, 21:55:39 »
No to świetnie. Na karte załaduj ESX 0.8.6 bo taki jest w romie a wersje sie muszą zgadzać. No i na początek do testowania dobre są demka WHOLE i WE ARE ALIVE , jak coś jest nie tak to sie wywalają i od razu wiadomo ;)
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #287 dnia: 2019.04.03, 20:41:54 »
Uruchamiania część dalsza. Niestety, w dalszym ciągu nie mam klawiatury (czekam na dostawę), dlatego ograniczyłem się do sprawdzenia, czy czytnik odczyta listę plików z karty SD. Lista się wyświetla, więc jakiś mały sukces jest. No i pomierzyłem temperatury na cieplejszych elementach. Najcieplejsze - mostek i LM2596 ok. >=50C (przy dłuższej chwili dotykania palcem - parzą), LM1117  i 1N5822 - 45C. Mniej grzeją się XILINXY, ale już nie tak jak LM-y. Grzeją się jeszcze Z80 (to chyba normalne) i AY-3-8912 (choć nie miałem podłączonych głośników). Reszta scalaków letnia, lub zimna. ZX zasilany był z zasilacza laboratoryjnego napięciem 12V, przy poborze prądu 380-395mA. Muszę powiedzieć, że jak na pracę na biegu jałowym, to całość dosyć mocno się grzeje. Z waszego doświadczenia to normalne, czy szukać przyczyny? Może dorzucić jakiś wentylator i wymusić chłodzenie? Napięcia zasilania na poszczególnych scalakach wydają się być ok. 4,85-4,93V i 3,26V. Trochę się martwię, że w małej obudowie od gumiaka kondensatory przy mostku szybko trafi szlag.

zaxon

  • *****
  • Wiadomości: 4059
Odp: Montujemy JS128
« Odpowiedź #288 dnia: 2019.04.04, 06:16:31 »
Pierwsze JS-y zeszły z "taśmy" w lipcu 2015.Jakoś do tej pory nie miałem sygnałów że są problemy a paru znajomych którzy kupili je jako pierwsi używa ich na codzień. Grzeje sie bo sie ma grzać.W porównaniu z typowym gumiakiem to i tak nic  :D
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #289 dnia: 2019.04.04, 07:11:02 »
Ale z Ciebie ranny ptaszek. To nie był zarzut do konstrukcji, tylko się chciałem się upewnić czy ten typ tak ma, czy szukać jakiejś przyczyny - zwarcia itp.

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #290 dnia: 2019.04.04, 19:39:00 »
JS128 mam i ja  8). Co prawda z prowizoryczną klawiaturą i bez obudowy, ale demka WHOLE i WE ARE ALIVE przeszły bez bólu, jakieś testy pamięci również. Szukam teraz obudowy od plusa w dobrym stanie i muszę wyszperać w garażu swój własnoręcznie zrobiony joystick, to polecimy z gierkami. Ach, łza się w oku kręci. No i trzeba pomyśleć na rozbudową zestawu. Jeszcze raz dziękuję za wsparcie i pomoc.

zaxon

  • *****
  • Wiadomości: 4059
Odp: Montujemy JS128
« Odpowiedź #291 dnia: 2019.04.04, 19:54:46 »
Fajnie widzieć kolejną działającą maszyne . Co do rannego ptaszka .. kto mówił że ja wogóle spałem ?  :P
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #292 dnia: 2019.04.07, 18:21:48 »
Mam jedno pytanko. Który z dostępnych interfejsów IDE dobrze działa z JS128?

zaxon

  • *****
  • Wiadomości: 4059
Odp: Montujemy JS128
« Odpowiedź #293 dnia: 2019.04.07, 18:35:22 »
Prawdopodobnie żaden, po to JS 128 ma wbudowane MMC.
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #294 dnia: 2019.04.07, 19:14:09 »
Dzięki, to nie będę eksperymentował w tym przypadku.

misiek2

  • ***
  • Wiadomości: 183
  • Miejsce pobytu:
    lubelskie
Odp: Montujemy JS128
« Odpowiedź #295 dnia: 2019.04.07, 21:27:47 »
U mnie działa czeski divide 5.7. Miał wymieniony wsad w gal r. Przed wymianą nie działał. Lotharek pisał, że działa Divide2k14. Montowanie divide w justspeccy to trochę sztuka dla sztuki, skoro jest wewnętrzny divmmc.
ZX Spectrum 128+ (toastrack), ZX Spectrum +3, Just Speccy, Amstrad CPC 464 + DDI3 z 512 kb ram

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #296 dnia: 2019.04.07, 21:36:26 »
Zgadzam się, że dołączanie dodatkowego interfejsu dla kart SD jest trochę bez sensu, tylko że ja chciałem podłączyć napęd FDD, lub HDD.

tooloud

  • *****
  • Wiadomości: 2537
  • Miejsce pobytu:
    Warszawa
  • mydłem go!
Odp: Montujemy JS128
« Odpowiedź #297 dnia: 2019.04.07, 22:02:35 »
a Z80IDE?
dużo sprzętu mało czasu.

Klaud

  • *****
  • Wiadomości: 4245
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: Montujemy JS128
« Odpowiedź #298 dnia: 2019.04.07, 22:03:21 »
Nie ma ROMu do 128K, wiec odpada.
KL
-----
R Tape loading error 0:1

asmod

  • *
  • Wiadomości: 36
Odp: Montujemy JS128
« Odpowiedź #299 dnia: 2019.05.01, 21:10:44 »
Mojej walki z JS128k część dalsza. Ponieważ zostało mi drugie tyle scalaków z poprzedniego montażu postanowiłem poskładać drugi egzemplarz JSa z przeznaczeniem dla siostrzeńca, bo widzę że się chłop zapalił. Dokupiłem od zaxona wszystkie brakujące elementy i przystąpiłem do montażu. Tym razem postanowiłem sam zaprogramować wszystkie pamięci i gala. Niestety, poległem na programowaniu układu GAL16V8A-25LP. Próbowałem obu dostępnych wersji wsadu na forum, jak i próbowałem przegrać z chodzącego układu. Za każdym razem efekt ten sam - kaszanka na ekranie. Po włożeniu scalaka programowanego przez zaxona wszystko OK. Używam programatora TL866II+, scalak kupiony jako nowy z TV SAT ELECTRONIC. Podejrzewam scalaka. Gdzie można dostać GAL16V8D-15LPN, bo gdzieś mignęło mi na forum, że ta wersja co mam nie działa? . Mam też problem z DIVMMC, pierwszy ekran z testami się wyświetla standardowo (chyba, bo dość szybko znika), przechodzi do systemu, ale zwarcie pinów J8 nie startuje MMC. Układy U16,U18 i U19 są ok, działają w drugim egzemplarzu.