Autor Wątek: Montujemy JS128  (Przeczytany 17469 razy)

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #240 dnia: 2019.03.08, 12:54:20 »
Po wymianie pamięci komputer się uruchamia ale nie działa klawiatura. Podstawiłem jescze raz rom diagnostyczny i w teście górnego ramu jest błąd banku 2. Jest informacja o przejżeniu układów IC15,IC17,IC21. Tyle tylko, żę przy kolejnym włączeniu komputera podaje informacje o układach z IC15, IC16, IC17, IC18, IC19, IC20, IC21, IC22. Jest to oznaczenie scalaków dla 128k, dla js128 jest to prawy blok ramu. Układy w podstawkach kontaktują. Gdzie leży problem?

zaxon

  • *****
  • Wiadomości: 4004
Odp: Montujemy JS128
« Odpowiedź #241 dnia: 2019.03.08, 12:57:52 »
Masz jakieś inne z80? spróbuj podmienić.Klawiatura od gumiaka czy od plusa?
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #242 dnia: 2019.03.08, 13:10:15 »
Klawiatura od gumiaka, tylko ona w teście pozwala uruchomić test górnego ramu, gdy podstawię od plusa całkowita martwica. W boot menu komputera obydwie martwe. I jeszcze jedno w diagnostyce jest informacja: Diagnostic hardware not detected(M1/ bad?). Rozkręcam harlequina by wyłuskać Z80.....

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #243 dnia: 2019.03.08, 13:28:39 »
Podstawiłem , teraz wywalił 2 i 6 bank. Powróciłem do tego samego i test przechodzi, wygląda to na,że nie kontaktuje w podstawce. Teraz klawiaturka działa......podstawiam scalaki od divmmc.....

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #244 dnia: 2019.03.10, 17:00:56 »
Po założeniu zworki J6 nie zgłasza się divmmc, na ekranie krzaczki. Eeprom AT28c64b zaprogramowany wsadem 8.6 i podstawiony do DivMMc EnJOY, jest ok . Zasilanie xilinxa to 3.28V. Gdzie szukać przyczyny?

Drak

  • **
  • Wiadomości: 79
Odp: Montujemy JS128
« Odpowiedź #245 dnia: 2019.03.10, 17:07:00 »
Zworka chyba ma być zdjęta. Założona odcinać ma divmmc.
Timex 1000 + 1016, ZX Spectrum 48K, ZX Spectrum +2 (szary), Timex TC2048, divIDE, Harlequin, Chrome128, JS128, KempAY

zaxon

  • *****
  • Wiadomości: 4004
Odp: Montujemy JS128
« Odpowiedź #246 dnia: 2019.03.10, 17:34:04 »
J6 założona , MMC włączone. Obejrzyj dokłądnie Xilinxa, lutowałem je i programowałem po omacku, może któraś noga sie nie trzyma. U19 założony? Ram założony? Rom normalny musi być a nie testowy.
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #247 dnia: 2019.03.10, 20:29:11 »
Mam to Zaxon, cały rząd w xilinxie nie przylutowany, pod lupą wychwyciłem. Po dociśnięciu pinów odzywa się MMC.

zaxon

  • *****
  • Wiadomości: 4004
Odp: Montujemy JS128
« Odpowiedź #248 dnia: 2019.03.10, 20:34:20 »
Upssssss..... Sorry.,
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #249 dnia: 2019.03.10, 21:24:48 »
MMC ogarnięte, wszystko działa jak należy, ale gierki w trybie 48 wieszają się. Podstawiłem kolejny raz rom diagnostyczny i kolejny raz awaria banku 2. Podstawka pod Z80 jest ok, podmiana procesora wcześniejsza nic nie dała.

zaxon

  • *****
  • Wiadomości: 4004
Odp: Montujemy JS128
« Odpowiedź #250 dnia: 2019.03.11, 10:45:58 »
Ale ten upper ram to ci wariuje losowo czy cały czas te same układy  ? C26 180 pf założony? ( co sie dzieje jak go wylutujesz ? ) Przydało by sie zdjęcie płyty ale takie na którym coś widać......
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #251 dnia: 2019.03.11, 17:50:43 »
Wariuje losowo, C26 rzecz jasna wlutowany, po usunieciu to samo.

zaxon

  • *****
  • Wiadomości: 4004
Odp: Montujemy JS128
« Odpowiedź #252 dnia: 2019.03.12, 13:39:33 »
Ok, jak wariuje losowo to miałem takie przypadki przy jednej parti Z80 z dziwnego źródła. Działały ok na innych modelach, z JS128 właśnie górne 64k ramu wariowało . Ewentualnie PCF ale mało prawdopodobne. O fotke płyty nadal proszę, oferta diagnostyki u mnie nadal aktualna . Na 100 % ok działa z80 z TME https://www.tme.eu/pl/details/z84c0006peg/mikrokontrolery-pozostale/zilog/
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993

ACULA2

  • *
  • Wiadomości: 32
  • Miejsce pobytu:
    Rogowo
Odp: Montujemy JS128
« Odpowiedź #253 dnia: 2019.03.15, 19:16:18 »
Zwyciestwo Zaxon !!! Winny był procesor tak jak mówiłeś. Zamówiłem ze żródła, które wskazałeś.
Teraz test ramu przechodzi bezbłędnie a  gry nie wieszają się. Dziękuje za cenne rady.

zaxon

  • *****
  • Wiadomości: 4004
Odp: Montujemy JS128
« Odpowiedź #254 dnia: 2019.03.15, 19:19:07 »
No to udanej zabawy ;)
Siedem kilo smalcu,gesich jajek kopa,zeby moc to polknac tegiego trza chlopa. GG 3456993