Autor Wątek: ZX 128k +2  (Przeczytany 3665 razy)

maciekb

  • ***
  • Wiadomości: 121
  • Miejsce pobytu:
    Warszawa
ZX 128k +2
« dnia: 2019.08.02, 22:57:49 »
Cześć

Trochę się będę chwalił, trochę żalił, a przede wszystkim proszę o pomoc w rozwiązaniu problemów :-)
Od wczoraj mam ZX 128k +2 - francuskiego szaraczka. Okazał się taką olxową niespodzianką, bo nie spodziewałem się francuskiego, a sprzedający zrobił tak zdjęcia, żeby nie dało się tego przewidzieć. Nic to, język jak język, zresztą ROM Amstrad 40068 jest w podstawce i zakładam, że da się go podmienić. Bardziej zmartwił mnie brak modulatora, bo z komputerem dostałem jakiś kabel (DIN6-SCART), którego nijak nie dało się podłączyć. Po konsultacjach z Trojackiem (dzięki za cierpliwość) udało się ustalić, że przy moim układzie zworek na płycie do kompa będzie pasował kabelek jak do +2A/B/+3. Taki też dziś poskładałem i z wypiekami na twarzy uruchomiłem sprzęt.
Pierwsze wrażenie: rozczarowanie obrazem - cała lewa strona "latająca", włączenie magnetofonu to jakieś totalne zakłócenia. Jednak po paru minutach wszystko się uspokoiło. Zapewne elektrolity trochę się "odświeżyły" i zaczęły wreszcie filtrować to co miały filtrować.
Drugie wrażenie: jaki on jest fajny! Że też nie miałem takiego w latach 80-tych :-) No dobra - magnetofon nie ma licznika (co za baran to wymyślił??), porty joysticków jakieś bez sensu (ale przynajmniej DB9, a nie jak te od RS'a, czy klawiatury numeryczniej) - tyle wad. Za to zalety: bardzo fajna klawiatura, reset, dioda sygnalizująca włączenie - no tego brakowało w gumiakach.
Do tego trafił mi się bardzo ładny egzemplarz - praktycznie brak śladów używania, fabryczna folia na naklejce magnetofonu, no po prostu śliczny jest :-) W środku nie widać ingerencji, przeróbek, napraw - wygląda na fabryczny.

Na koniec problemy: po jakimś czasie od włączenia obraz zaczyna się przełączać na czarny (znikają kolory) i jednocześnie przeskakiwać w lewo, po chwili wraca do normy i tak w kółko. Ogólnie mam wrażenie, że cały obraz przesunięty jest w prawo. Widać to szczególnie przy wczytywaniu kasety, gdy latają paski na ramce - lewa ramka jest szersza od prawej. Co to może być? Nie ukrywam, że przewód który zrobiłem jest dość długi (ma ponad 3m), dodatkowo wlutowałem rezystory 150R w tory RGB. Jutro może spróbuję z krótszym przewodem.
Niestety chyba AY nie żyje - nie mam dźwięku :-( W trakcie wczytywania danych z kasety słychać "piski", więc przewód raczej poprawnie polutowany, ale później jest głucho. Da się coś jeszcze zrobić poza próbą podmiany?
« Ostatnia zmiana: 2019.08.02, 23:15:43 wysłana przez maciekb »

trojacek

  • *****
  • Wiadomości: 5516
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #1 dnia: 2019.08.02, 23:25:23 »
Podejrzewam, że Twój kabel SCART nie "transportuje" dźwięku.
Na wyjściu audio (tego obok RF, którego nie masz) też nic nie ma?
Masz multimetr, by "przedzwonić" kabel?
Co do obrazu - na ilu TV sprawdzałeś i na jakich? Czy na linii synchronizacji też dałeś rezystor 150 omów? Jakie napięcia masz na pinach 8 i 16 złącza SCART? Czy napięcie 12V na wyjściu przetwornicy jest stabilne? Może trzeba jednak recap zrobić.
Wymiana ROM-u to pryszcz, przekładasz i działa :) Może być EPROM 27C256, chyba nawet bez żadnych przeróbek druku zadziała, nie pamiętam dokładnie.
Porty joysticków pracują w standardzie SJS. Musisz mieć albo specjalne joysticki SJS, ale takie z przełączaniem trybu. Bywają też joysticki z dwoma kabelkami, wtedy korzystasz z szarego.
« Ostatnia zmiana: 2019.08.02, 23:42:41 wysłana przez trojacek »

maciekb

  • ***
  • Wiadomości: 121
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #2 dnia: 2019.08.03, 00:16:02 »
No niestety transportuje. Tak jak pisałem, słychać magnetofon, mogę sobie też w Basicu beepować - to wszystko słychać przez TV. Na wyjściu audio jest tak samo.
Co do sprawdzenia obrazu, to mam jeden TV i na nim sprawdziłem, a jest to jakiś stary Funai. Na pinie 8 nie mam nic, bo nic tam nie podłączyłem, na 16 idzie 12V.
Stabilności napięcia nie jestem w stanie ocenić, bo multimetr ma sporą bezwładność, a oscyloskop muszę dopiero wygrzebać z gratów. Na multimetrze jest stabilne, ale też mi się wydaje, że recap nie zaszkodzi.
Do joysticków to sobie planowałem zrobić przejściówki zamieniające kolejność pinów i chyba będzie ok?

damik

  • Rosin sniffer
  • *****
  • Wiadomości: 835
  • Miejsce pobytu:
    Bytom
  • ZX Everyday
Odp: ZX 128k +2
« Odpowiedź #3 dnia: 2019.08.03, 00:16:18 »
Mam takiego jednego Francuza i w zasadzie poza brakującym modulatorem i enkoderem PAL to pełnowartościowy +2 ;)
Bez problemu można wstawić angielski EPROM, i jeśli mogę coś zaproponować to Winbond 27E257 (kasowany elektrycznie EPROM) bo nie trzeba się pitolić z UV w razie potrzeby reprogramowania (na ali są tanie jak barszczyk bez krokieta).  ;D

Potwierdzam że kabel w tym modelu pasuje z +2A/B bezproblemowo.

Apropos Joysticków to zrobiłem sobie takie proste adaptery typu gniazdo-wtyk z przeplotem do standardu Atari czy C64, bo takie joye są tańsze i łatwiej dostępne.

Można jeszcze w nim "oddeszczyć" obraz poprzez wymianę układu HAL/PAL na odpowiednio zaprogramowany GAL16V8 by poprawić błąd konstrukcyjny ;), wymagane jest wtedy wylutowanie starego układu i wstawienie podstawki 20pin i jeden mały kabelek z tej podstawki do procka.


 
« Ostatnia zmiana: 2019.08.03, 00:24:58 wysłana przez damik »
Wszystkiego po trochu: schwarz, mydło i powidło...

maciekb

  • ***
  • Wiadomości: 121
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #4 dnia: 2019.08.03, 00:29:56 »
W sumie już się trochę przyzwyczaiłem do tego francuskiego szwargotu którym mnie raczy po uruchomieniu ;-) Jeśli nie znajdę jakichś francuskich cudów w Basicu, to chyba nawet odpuszczę sobie na razie upgrady.
Dementuję te podłe kłamstwa, które przed chwilą wypisywałem, że AY nie gra. Przez port audio coś tam idzie. Zmieniłem słuchawki i na drugich mam muzyczkę Yerzmyeya :-) Wygląda na to, że pierwsze słuchawki coś nie kontaktowały - port jest w końcu mono, minijack stereo i jak porównuję dwa egzemplarze to trochę różnią się kształtem. Dźwięk cichy, ale tu potrzeby pewnie wzmacniacz. Nadal jednak nie rozumiem dlaczego na TV idzie mi beepanie, a nic z AY. Zaraz jeszcze raz sprawdzę ten nieszczęsny kabel.

andy

  • *****
  • Wiadomości: 813
  • Miejsce pobytu:
    Kielce Wsch.
Odp: ZX 128k +2
« Odpowiedź #5 dnia: 2019.08.03, 10:36:09 »
Apropos Joysticków to zrobiłem sobie takie proste adaptery typu gniazdo-wtyk z przeplotem do standardu Atari czy C64, bo takie joye są tańsze i łatwiej dostępne.
Można też zrobić przelotkę z 2 wtyczek do 3 gniazd robiąc dodatkowo  "Cursor". Przydaje się do starszych gier. 
pzdr
a.
POKE 35899,0  ZX 81, ZX Spectrum +, ZX Spectrum Harlequin , ZX Spectrum +2, ZX Max 48 & 128, Chrome 128 (w lutowaniu), TC 2048, divIDE, CPC 464

trojacek

  • *****
  • Wiadomości: 5516
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #6 dnia: 2019.08.03, 12:25:40 »
Nadal jednak nie rozumiem dlaczego na TV idzie mi beepanie, a nic z AY. Zaraz jeszcze raz sprawdzę ten nieszczęsny kabel.

Sprawdź. Bo audio out jest połączone z LK8, nic po drodze nie ma. A z LK8 masz audio doprowadzone na pin 3 złącza DIN.
Przynajmniej tak wynika ze schematu.

maciekb

  • ***
  • Wiadomości: 121
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #7 dnia: 2019.08.03, 14:28:49 »
A czy audio out to nie jest jakieś takie "sprytne" gniazdo, że jak się w nie wetknie wtyczkę to odcina wyjście na DIN8? Pytam, bo jak coś do niego podłączam, to w głośnikach TV słychać głośne trzaski - może w tym gnieździe jest jakiś problem?

trojacek

  • *****
  • Wiadomości: 5516
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #8 dnia: 2019.08.03, 14:55:42 »
Może być zwarcie w tym gniazdku jack.

Boyo

  • *****
  • Wiadomości: 621
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #9 dnia: 2019.08.05, 09:41:43 »
W sumie już się trochę przyzwyczaiłem do tego francuskiego szwargotu którym mnie raczy po uruchomieniu ;-) Jeśli nie znajdę jakichś francuskich cudów w Basicu, to chyba nawet odpuszczę sobie na razie upgrady.
No co Ty, ROMu nie zmieniaj. Francuska wersja to rzadkość, natomiast "anglików" mają wszyscy :)
Z tego co pamiętam mam kabelek RGB, który oryginalnie był dostarczany z komputerem - nawet ma kolor szary i wydaje mi się że dźwięk także przez niego "idzie". Dzisiaj mam sporo wolnego czasu i może to jest dobry moment, aby "odkurzyć" ten sprzęt.
ZX81 / 2x ZX Spectrum 48kB / ZX Spectrum+ 48kB / Inves Spectrum+ / ZX Spectrum+ 128kB / 2x ZX Spectrum +2 / ZX Spectrum +2A / ZX Spectrum +3 / Didaktik Gama / 2x TC 2048 / JustSpeccy 128K
A500 2,5MB RAM Gotek HxC / A1200 Blizzard 1220/4

maciekb

  • ***
  • Wiadomości: 121
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #10 dnia: 2019.08.07, 14:07:19 »
Sprawdź. Bo audio out jest połączone z LK8, nic po drodze nie ma. A z LK8 masz audio doprowadzone na pin 3 złącza DIN.
Przynajmniej tak wynika ze schematu.
Na schemacie na wyjściu AY mam tranzystor TR6, który zdaje się robi za wzmacniacz. Gdzieś dalej w tor audio wplatany jest sygnał z CPU, czyli pewnie to co na gumiaku szło na buzzer. Jak pisałem sygnał buzzera jest słyszalny przez TV, zaś na wyjściu audio (mini-jack) mam zarówno buzzer jak i bardzo ciche wyjście AY. Może problem jest z tym tranzystorem i za niskim poziomem sygnału dochodzącym do TV?

trojacek

  • *****
  • Wiadomości: 5516
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #11 dnia: 2019.08.07, 14:26:14 »
Może ten tranzystor siedzi odwrotnie?

maciekb

  • ***
  • Wiadomości: 121
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #12 dnia: 2019.08.07, 14:47:45 »
Jest wlutowany zgodnie z nadrukiem na płycie, ale mam obecnie tylko zdjęcie z góry, więc nie widzę jego oznaczeń, nie wiem jak ma wyprowadzone nogi. Sprawdzę to dopiero jak wrócę do domu. Na schemacie jest BC239, może ktoś zerknąć, czy taki ma być?

Klaud

  • *****
  • Wiadomości: 4934
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: ZX 128k +2
« Odpowiedź #13 dnia: 2019.08.07, 15:17:32 »
Taki (BC239) jest na schemacie, ale moim zdaniem możesz zastosować prawie każdy inny niskoszumowy NPN, np. BC549/550.  Jeśli takiego nie masz od biedy mogą być 2N3904 lub 2N2222, ale one mają inną kolejność nóg. Ten TR6 robi za jednostopniowy wzmacniacz audio, do tego mono, więc żadnych cuda-wianków tam nie ma.
KL
-----
R Tape loading error 0:1

maciekb

  • ***
  • Wiadomości: 121
  • Miejsce pobytu:
    Warszawa
Odp: ZX 128k +2
« Odpowiedź #14 dnia: 2019.08.07, 17:16:42 »
Mam KC239B i BC549B, ale one chyba mają inne wzmocnienie?