Autor Wątek: ZX Spectrum+  (Przeczytany 1667 razy)

Macminik

  • *
  • Wiadomości: 31
  • Miejsce pobytu:
    Kraków
ZX Spectrum+
« dnia: 2020.03.25, 12:06:39 »
Więc na początku się pochwalę, zostałem posiadaczem ZX Spectrum+ w komplecie z pudełkiem i zasilaczem. A teraz do meritum.

Postanowiłem przystosować go do złącza Composite. Obraz na TV jest lekko rozmyty, nieostry. Dużo gorszy niż na drugim Spectrum. Kable te same itd. Wsadzenie kondensatora 100uF coś pomoże?

Kwestia druga, komputer był napewno naprawiany przez jakiegoś człowieka z Poznania - jest plomba ;-)

Trochę drutowana membrana, ale mam już zamówioną nową. Teraz obudowa się suszy, bo brała kąpiel.

Jednak bardziej zastanawiają mnie drobne modyfikacje przy głośniku i na płycie. Czerwony kabel idzie do szyny krawędziowej.

Klaud

  • *****
  • Wiadomości: 5094
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: ZX Spectrum+
« Odpowiedź #1 dnia: 2020.03.25, 14:00:28 »
Możesz podliknować zdjęcia większej rozdzielczości?

Do którego pola złącza krawędziowego jest podpięty ten czerwony kabelek?
KL
-----
R Tape loading error 0:1

trojacek

  • *****
  • Wiadomości: 5640
  • Miejsce pobytu:
    Warszawa
Odp: ZX Spectrum+
« Odpowiedź #2 dnia: 2020.03.25, 14:10:45 »
Obraz na TV jest lekko rozmyty, nieostry. Dużo gorszy niż na drugim Spectrum. Kable te same itd. Wsadzenie kondensatora 100uF coś pomoże?

Nic. Jak umarłemu kadzidło. Pomoże przegląd przetwornicy, to tak na początek.

Cytuj
Jednak bardziej zastanawiają mnie drobne modyfikacje przy głośniku i na płycie. Czerwony kabel idzie do szyny krawędziowej.

No właśnie, ciekawe do którego pola, jak już pytał Klaud. Generalnie to połączenie nie ma żadnego sensu, chyba że to połączenie nie idzie do złącza krawędziowego, tylko do gniazda MIC, to może coś tam popiskuje ;)
Inna hipoteza - właściciel miał interfejs z AY, którego wyjście audio było na którymś niewykorzystanym pinie złącza krawędziowego i tak sobie "przerutował" (a raczej przedrutował), by grało z głośniczka.

BTW, wrzuciłeś fotki w ciekawej rozdzielczości :) Przynajmniej większość z nich.

Macminik

  • *
  • Wiadomości: 31
  • Miejsce pobytu:
    Kraków
Odp: ZX Spectrum+
« Odpowiedź #3 dnia: 2020.03.25, 15:10:07 »
Ah zdaj się na skrypt i wrzuć na "pałę" do konwersji to później kwiatki wychodzą. Ok. Jeszcze raz.

A co do czerwonego kabelka, to jest pociągnięty do 4 (od lewej strony) pinu złącza krawędziowego. To ostatni pin przed "wcięciem" na złączu krawędziowym.


Klaud

  • *****
  • Wiadomości: 5094
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: ZX Spectrum+
« Odpowiedź #4 dnia: 2020.03.25, 15:16:11 »
Co to za rzeźba z tymi 3 tranzystorami przy liniach zasilających? Dobrze widzę, że tam też są: rezystor 390R/1W, zener 3.6V i wielki kondensator na 16V?

Pole nr 4 złącza krawędziowego na górnej stronie płyty jest wolne.
KL
-----
R Tape loading error 0:1

trojacek

  • *****
  • Wiadomości: 5640
  • Miejsce pobytu:
    Warszawa
Odp: ZX Spectrum+
« Odpowiedź #5 dnia: 2020.03.25, 16:03:06 »
Co to za rzeźba z tymi 3 tranzystorami przy liniach zasilających? Dobrze widzę, że tam też są: rezystor 390R/1W, zener 3.6V i wielki kondensator na 16V?

To chyba sekwencer załączający napięcia :D

Maryjan

  • *****
  • Wiadomości: 5243
  • Miejsce pobytu:
    Skarżysko-Kam.
  • Scotch whiskey and West Highland Terrier
Odp: ZX Spectrum+
« Odpowiedź #6 dnia: 2020.03.25, 16:31:53 »
Były stosowane takie wynalazki, żeby napięcia na pamięciach pojawiały się w odpowiedniej kolejności.
Ogólnie, nic to nie dawało. Jak leciała przetwornica, to i tak to nie pomagało.
"... podobno są dwie szkoły, Falenicka i Otwocka."

Macminik

  • *
  • Wiadomości: 31
  • Miejsce pobytu:
    Kraków
Odp: ZX Spectrum+
« Odpowiedź #7 dnia: 2020.03.26, 20:18:57 »
Bardzo dziękuję wszystkim za pomoc. Komputer wyszorowany i jest teraz czyściutki. Nowa folia założona, wszystkie klawisze działają, choć przestawić się ze zwykłego Spectrum na Plusa wymaga chwili... zastanowienia.

Nieco bardziej rozmyty obraz... trudno. Narazie niech zostanie. Nie czuję się na siłach by to jakoś poprawiać. Tragedii nie ma. No i teraz... trzeba polować na kolejny model do kolekcji ;-)

Klaud

  • *****
  • Wiadomości: 5094
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: ZX Spectrum+
« Odpowiedź #8 dnia: 2020.03.26, 20:45:47 »
Wrzuć zdjęcie tego rozmytego obrazu, może ktoś coś poradzi.
KL
-----
R Tape loading error 0:1

sajmosia

  • *****
  • Wiadomości: 1210
  • Miejsce pobytu:
    Terra Prime
Odp: ZX Spectrum+
« Odpowiedź #9 dnia: 2020.03.26, 22:14:34 »
Komputer wyszorowany i jest teraz czyściutki...Nieco bardziej rozmyty obraz...

Moze poczekaj az wyschnie ...

Macminik

  • *
  • Wiadomości: 31
  • Miejsce pobytu:
    Kraków
Odp: ZX Spectrum+
« Odpowiedź #10 dnia: 2020.03.27, 10:43:23 »
Wrzuć zdjęcie tego rozmytego obrazu, może ktoś coś poradzi.

A może ja przesadzam z tym rozmyciem ekranu ?


Klaud

  • *****
  • Wiadomości: 5094
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: ZX Spectrum+
« Odpowiedź #11 dnia: 2020.03.27, 10:55:28 »
Wymień kondensatory elektrolityczne, szczególnie te na linii zasilającej +12V i powinno pomóc.
KL
-----
R Tape loading error 0:1

trojacek

  • *****
  • Wiadomości: 5640
  • Miejsce pobytu:
    Warszawa
Odp: ZX Spectrum+
« Odpowiedź #12 dnia: 2020.03.27, 11:08:14 »
Ale to jest composite, czy z modulatora? Bo na zdjęciach nie widać moda, zrobiłeś go już?
Jeśli to obraz z modulatora, to takie rozmycie nie jest niczym nadzwyczajnym.

Macminik

  • *
  • Wiadomości: 31
  • Miejsce pobytu:
    Kraków
Odp: ZX Spectrum+
« Odpowiedź #13 dnia: 2020.03.27, 12:08:18 »
To już po modzie. Leci po composite bez kondensatora. Połączyłem "drucikiem" jak nóżka z kondensatora.... pewnie ten drucik pochodzi nawet z jakiegoś kondensatora elektrolitycznego.

trojacek

  • *****
  • Wiadomości: 5640
  • Miejsce pobytu:
    Warszawa
Odp: ZX Spectrum+
« Odpowiedź #14 dnia: 2020.03.27, 12:09:15 »
Ale odciąłeś wyjście od elektroniki modulatora?