Autor Wątek: Vectrex  (Przeczytany 1126 razy)

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Vectrex
« dnia: 2020.10.14, 15:14:20 »
Dzień dobry szanownemu gronu :)

Wpadła mi w ręce ta konsola. Uruchamia się ale nic więcej. Nie działa pad. Tzn. nie wiem czy to wina samego pada czy elektroniki wewnątrz. Ściągnąłem serwisówkę  i ewentualnie poprosiłbym o podpowiedzi, co i gdzie sprawdzać.
Na razie po uruchomieniu nie pokazuje się słynna plansza startowa tylko wskakuje od razu gra, ale nie reaguje na pada. Postaram się posprawdzać napięcia i drożność przewodów i dam znać. Liczę na waszą pomoc w razie czego :D
Pozdrawiam
Wojtek

damik

  • Rosin sniffer
  • *****
  • Wiadomości: 1173
  • Miejsce pobytu:
    Bytom
  • ZX Everyday
Odp: Vectrex
« Odpowiedź #1 dnia: 2020.10.14, 15:27:30 »
Zacząłbym od przegwizdania pada miernikiem czy nie ma przerw na kablu i czy styki działają w padzie.
Warto też sprawdzić czy styki aby nie mają zwarcia.
Wszystkiego po trochu: schwarz, mydło i powidło...

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #2 dnia: 2020.10.14, 15:52:19 »
Konsola bez pada uruchamia się tak samo jak opisałem, więc przypuszczam, że to nie jego wina. Ale oczywiście też sprawdzę. Wieczorem :)
Pozdrawiam
Wojtek

damik

  • Rosin sniffer
  • *****
  • Wiadomości: 1173
  • Miejsce pobytu:
    Bytom
  • ZX Everyday
Odp: Vectrex
« Odpowiedź #3 dnia: 2020.10.14, 19:28:03 »
Jeśli to nie sam pad to może być ubity układ dźwiękowy IC208 AY 3-8912, bo to z jego portu IO obsługiwane są pady w tym ustrojstwie.
BTW. Czy masz jakiś dźwięk z głośnika?
« Ostatnia zmiana: 2020.10.14, 19:50:36 wysłana przez damik »
Wszystkiego po trochu: schwarz, mydło i powidło...

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #4 dnia: 2020.10.14, 20:36:52 »
Dźwięk jest na szczęście.
Pozdrawiam
Wojtek

damik

  • Rosin sniffer
  • *****
  • Wiadomości: 1173
  • Miejsce pobytu:
    Bytom
  • ZX Everyday
Odp: Vectrex
« Odpowiedź #5 dnia: 2020.10.14, 21:04:55 »
Podmień tego AY i wtedy sprawdź czy pad działa, bo może ma tylko port upalony a reszta działa.
Wszystkiego po trochu: schwarz, mydło i powidło...

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #6 dnia: 2020.10.16, 16:59:44 »
Rozebrałem sprzęt. W środku niezły bajzel. Pad sprawdzony. Oprócz jednego niedomagającego przycisku wszystko działa ok. Na złączach są prawidłowe napięcia 5v i -5V. Na razie nadal brak reakcji. Czasem jak zwierałem na dłużej któryś z przycisków to gra się uruchamiała. Sprawdziłem bezpośrednio na płycie pojemność kondensatorów podpiętych pod piny złącza to podawało dosyć dziwne pojemności ale może to wina spiętych razem z nimi obwodów. Musiałbym wylutować kondensatory i sprawdzić luzem.
Edit.
Własnie zauważyłem, że powinny być trzy napięcia 5v, posprawdzam jeszcze raz.
AY niestety nie mam na podmiankę.
Pozdrawiam
Wojtek

damik

  • Rosin sniffer
  • *****
  • Wiadomości: 1173
  • Miejsce pobytu:
    Bytom
  • ZX Everyday
Odp: Vectrex
« Odpowiedź #7 dnia: 2020.10.16, 18:54:19 »
Trochę masz Pan syfex w tej budzie  ;D
Taka ilość kurzu z odrobiną wilgoci potrafi czynić cuda w elektronice  :P
Wszystkiego po trochu: schwarz, mydło i powidło...

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #8 dnia: 2020.10.17, 19:36:54 »
Jak jest z wymienialnością AY-3-8912 vs. AY-3-8912A ? Bo fabrycznie jest bez A
Mogę wyciągnąć z innego kompa wersję z A ale nie wiem czy są kompatybilne.
Pozdrawiam
Wojtek

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #9 dnia: 2020.10.17, 19:56:52 »
Sam sobie odpowiem. Znalazłem stronę, na której ktoś miał podobny problem z podmianą w Vectrex-ie. Działa bezproblemowo. No to biorę się do roboty.
Pozdrawiam
Wojtek

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #10 dnia: 2020.10.17, 20:39:59 »
No i wszystko się wyjaśniło. Vectrex ożył. Działa prawidłowo. To teraz recap i chyba muszę w padzie zamienić gumowe przyciski na microswitche, bo nie mam innego pomysłu. Słyszałem o lakierach przewodzących ale nie wiem na ile to wystarczy.
Druga sprawa. Nie ma ktoś na zbyciu AY-ka ? Ewentualnie proszę o podpowiedź, gdzie go najlepiej nabyć.
Pozdrawiam
Wojtek

Klaud

  • *****
  • Wiadomości: 5368
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: Vectrex
« Odpowiedź #11 dnia: 2020.10.17, 21:06:45 »
Jedna wersja AY ma wewnętrzne pull-upy dla portu I/O a druga wymaga zewnętrznych. Daj zdjęcie płytki, będzie łatwiej coś doradzić.
KL
-----
R Tape loading error 0:1

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #12 dnia: 2020.10.17, 21:43:34 »
Schemat wystarczy ?
Pozdrawiam
Wojtek

Klaud

  • *****
  • Wiadomości: 5368
  • Miejsce pobytu:
    trzecia planeta od Słońca
  • KL
Odp: Vectrex
« Odpowiedź #13 dnia: 2020.10.18, 09:05:49 »
Przy wersji A należałoby dodać drabinkę rezystorów 2k2 lub 4k7 jako pull-upy do I/O. Ale jeśli jest dużo miejsca na płytce wsadziłbym tam AY-3-8910 przez przejściówkę. 8910 są łatwo dostępne, produkowane przez kilka firm i są stosunkowo tanie.
KL
-----
R Tape loading error 0:1

avision

  • ***
  • Wiadomości: 230
  • Miejsce pobytu:
    dolny śląsk
Odp: Vectrex
« Odpowiedź #14 dnia: 2020.10.19, 21:36:18 »
Ktoś by podpowiedział, co może być powodem lekkiego falowania obrazu w kineskopie ? :)
Schemat w załączniku.
Pozdrawiam
Wojtek